import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\byou+()|u+s";
final String string = "you youyou youyouyou u uu uuu Can't wait to see youuuu uuuuyou youuuuuyou uuyouuu you you youyou youyouyou u uu uuu Can't wait to see youuuu uuuuyou youuuuuyou uuyouuu\n\n"
+ " I want to film the bayou with you and put it on youtube,";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}