#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<meta\s*?name="(?:ncbi_uidlist|citation_pmid)"\s*?content="(\d{8})"\s*?\/?>"
Local $sString = "<meta name="ncbi_uidlist" content="12345678" /><meta name="citation_pmid" content="87654321" />"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")