package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<meta\s*?name="(?:ncbi_uidlist|citation_pmid)"\s*?content="(\d{8})"\s*?\/?>`)
var str = `<meta name="ncbi_uidlist" content="12345678" /><meta name="citation_pmid" content="87654321" />`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}