$re = '/<meta\s*?name="(?:ncbi_uidlist|citation_pmid)"\s*?content="(\d{8})"\s*?\/?>/';
$str = '<meta name="ncbi_uidlist" content="12345678" /><meta name="citation_pmid" content="87654321" />';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);