use strict;
my $str = '<meta name="ncbi_uidlist" content="12345678" /><meta name="citation_pmid" content="87654321" />';
my $regex = qr/<meta\s*?name="(?:ncbi_uidlist|citation_pmid)"\s*?content="(\d{8})"\s*?\/?>/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}