re = /<meta\s*?name="(?:ncbi_uidlist|citation_pmid)"\s*?content="(\d{8})"\s*?\/?>/
str = '<meta name="ncbi_uidlist" content="12345678" /><meta name="citation_pmid" content="87654321" />'
# Print the match result
str.match(re) do |match|
puts match.to_s
end