using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<meta\s*?name=""(?:ncbi_uidlist|citation_pmid)""\s*?content=""(\d{8})""\s*?\/?>";
string input = @"<meta name=""ncbi_uidlist"" content=""12345678"" /><meta name=""citation_pmid"" content=""87654321"" />";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}