using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[(?P<key>AA|BB|CC)\]\s*(?P<value>.*)";
string input = @"[AA] abcd 1234 !@#$ _+{}[]:""
[BB]abcd defg
[CC]";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}