$re = '/\[(?P<key>AA|BB|CC)\]\s*(?P<value>.*)/';
$str = '[AA] abcd 1234 !@#$ _+{}[]:"
[BB]abcd defg
[CC]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);