re = /\[(?P<key>AA|BB|CC)\]\s*(?P<value>.*)/
str = '[AA] abcd 1234 !@#$ _+{}[]:"
[BB]abcd defg
[CC]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end