package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\[(?P<key>AA|BB|CC)\]\s*(?P<value>.*)`)
var str = `[AA] abcd 1234 !@#$ _+{}[]:"
[BB]abcd defg
[CC]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}