import re
regex = re.compile(r"\[(?P<key>AA|BB|CC)\]\s*(?P<value>.*)")
test_str = ("[AA] abcd 1234 !@#$ _+{}[]:\"\n"
"[BB]abcd defg\n"
"[CC]")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")