// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\[(?P<key>AA|BB|CC)\]\s*(?P<value>.*)").unwrap();
let string = "[AA] abcd 1234 !@#$ _+{}[]:\"
[BB]abcd defg
[CC]";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}