#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\[(?P<id>[\d.]+)\]"
Local $sString = "[2.1.1.1] M_1.0_4.1.6.1: A requirement, may have any types "of symbols." ::==" & @CRLF & _
"" & @CRLF & _
"And multiple lines describing futher information about this requirement." & @CRLF & _
"" & @CRLF & _
"With the possibility of being completely empty, placeholders should not match."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")