const regex = new RegExp('\\[(?P<id>[\\d.]+)\\]', '')
const str = `[2.1.1.1] M_1.0_4.1.6.1: A requirement, may have any types "of symbols." ::==
And multiple lines describing futher information about this requirement.
With the possibility of being completely empty, placeholders should not match.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}