import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[(?P<id>[\\d.]+)\\]";
final String string = "[2.1.1.1] M_1.0_4.1.6.1: A requirement, may have any types \"of symbols.\" ::==\n\n"
+ "And multiple lines describing futher information about this requirement.\n\n"
+ "With the possibility of being completely empty, placeholders should not match.";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}