# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(([\/\\])\2{3})\2+|([\/\\])\3*/$1$3$3/gm;t' <<< "/////this///is//an////absolute//path
\\\\\this\\\is\\an\\\\absolute\\path"