use strict;
my $str = '/////this///is//an////absolute//path
\\\\\\\\\\this\\\\\\is\\\\an\\\\\\\\absolute\\\\path';
my $regex = qr~^(([/\\])\2{3})\2+|([/\\])\3*~mp;
my $subst = '$1$3$3';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";