#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(([/\\])\2{3})\2+|([/\\])\3*"
Local $sString = "/////this///is//an////absolute//path" & @CRLF & _
"\\\\\this\\\is\\an\\\\absolute\\path"
Local $sSubst = "$1$3$3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)