using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(([/\\])\2{3})\2+|([/\\])\3*";
string substitution = @"$1$3$3";
string input = @"/////this///is//an////absolute//path
\\\\\this\\\is\\an\\\\absolute\\path";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}