$re = '~^(([/\\\\])\2{3})\2+|([/\\\\])\3*~m';
$str = '/////this///is//an////absolute//path
\\\\\\\\\\this\\\\\\is\\\\an\\\\\\\\absolute\\\\path';
$subst = "$1$3$3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;