import Foundation
let pattern = #"^(([/\\])\2{3})\2+|([/\\])\3*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
/////this///is//an////absolute//path
\\\\\this\\\is\\an\\\\absolute\\path
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1$3$3"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)