# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(.*)\.(\d+)$/$1_$2/gm;t' <<< "2999.1049.00_GRB.1
2999.1049.00_GRB.165
toto.tata.00_GRB.1"