// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(.*)\.(\d+)$").unwrap();
let string = "2999.1049.00_GRB.1
2999.1049.00_GRB.165
toto.tata.00_GRB.1";
let substitution = "$1_$2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}