re = /(.*)\.(\d+)$/m
str = '2999.1049.00_GRB.1
2999.1049.00_GRB.165
toto.tata.00_GRB.1'
subst = '$1_$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result