using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*)\.(\d+)$";
string substitution = @"$1_$2";
string input = @"2999.1049.00_GRB.1
2999.1049.00_GRB.165
toto.tata.00_GRB.1";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}