use strict;
my $str = '2999.1049.00_GRB.1
2999.1049.00_GRB.165
toto.tata.00_GRB.1';
my $regex = qr/(.*)\.(\d+)$/mp;
my $subst = '$1_$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";