#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(.*)\.(\d+)$"
Local $sString = "2999.1049.00_GRB.1" & @CRLF & _
"2999.1049.00_GRB.165" & @CRLF & _
"toto.tata.00_GRB.1"
Local $sSubst = "$1_$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)