using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\w+ (\w+) (\d+) (\d+:\d+:\d+) (\d+)) (?:\d+ bytes )?From (.+)icmp_seq=\d+ (ttl=\d+ )?(.*)(time=(\d+.\d+) ms)?";
string input = @"Tue May 10 10:25:10 2016 64 bytes from egp-tl7794.egp.ap-hop-paris.fr (10.149.219.99): icmp_seq=5 ttl=127 time=1.45 ms
Tue May 10 10:26:44 2016 From 10.149.219.253 icmp_seq=8 Destination Host Unreachable
############
(\w+ (\w+) (\d+) (\d+:\d+:\d+) (\d+)) (?:\d+ bytes )?From (.+)icmp_seq=\d+ (ttl=\d+ )?(.*)(time=(\d+.\d+) ms)?";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}