const regex = /(\w+ (\w+) (\d+) (\d+:\d+:\d+) (\d+)) (?:\d+ bytes )?From (.+)icmp_seq=\d+ (ttl=\d+ )?(.*)(time=(\d+.\d+) ms)?/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\w+ (\\w+) (\\d+) (\\d+:\\d+:\\d+) (\\d+)) (?:\\d+ bytes )?From (.+)icmp_seq=\\d+ (ttl=\\d+ )?(.*)(time=(\\d+.\\d+) ms)?', 'gmi')
const str = `Tue May 10 10:25:10 2016 64 bytes from egp-tl7794.egp.ap-hop-paris.fr (10.149.219.99): icmp_seq=5 ttl=127 time=1.45 ms
Tue May 10 10:26:44 2016 From 10.149.219.253 icmp_seq=8 Destination Host Unreachable
############
(\\w+ (\\w+) (\\d+) (\\d+:\\d+:\\d+) (\\d+)) (?:\\d+ bytes )?From (.+)icmp_seq=\\d+ (ttl=\\d+ )?(.*)(time=(\\d+.\\d+) ms)?`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}