import re
regex = re.compile(r"(\w+ (\w+) (\d+) (\d+:\d+:\d+) (\d+)) (?:\d+ bytes )?From (.+)icmp_seq=\d+ (ttl=\d+ )?(.*)(time=(\d+.\d+) ms)?", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("Tue May 10 10:25:10 2016 64 bytes from egp-tl7794.egp.ap-hop-paris.fr (10.149.219.99): icmp_seq=5 ttl=127 time=1.45 ms\n"
"Tue May 10 10:26:44 2016 From 10.149.219.253 icmp_seq=8 Destination Host Unreachable\n\n\n"
"############\n"
"(\\w+ (\\w+) (\\d+) (\\d+:\\d+:\\d+) (\\d+)) (?:\\d+ bytes )?From (.+)icmp_seq=\\d+ (ttl=\\d+ )?(.*)(time=(\\d+.\\d+) ms)?")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")