import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\w+ (\\w+) (\\d+) (\\d+:\\d+:\\d+) (\\d+)) (?:\\d+ bytes )?From (.+)icmp_seq=\\d+ (ttl=\\d+ )?(.*)(time=(\\d+.\\d+) ms)?";
final String string = "Tue May 10 10:25:10 2016 64 bytes from egp-tl7794.egp.ap-hop-paris.fr (10.149.219.99): icmp_seq=5 ttl=127 time=1.45 ms\n"
+ "Tue May 10 10:26:44 2016 From 10.149.219.253 icmp_seq=8 Destination Host Unreachable\n\n\n"
+ "############\n"
+ "(\\w+ (\\w+) (\\d+) (\\d+:\\d+:\\d+) (\\d+)) (?:\\d+ bytes )?From (.+)icmp_seq=\\d+ (ttl=\\d+ )?(.*)(time=(\\d+.\\d+) ms)?";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}