use strict;
my $str = 'Tue May 10 10:25:10 2016 64 bytes from egp-tl7794.egp.ap-hop-paris.fr (10.149.219.99): icmp_seq=5 ttl=127 time=1.45 ms
Tue May 10 10:26:44 2016 From 10.149.219.253 icmp_seq=8 Destination Host Unreachable
############
(\\w+ (\\w+) (\\d+) (\\d+:\\d+:\\d+) (\\d+)) (?:\\d+ bytes )?From (.+)icmp_seq=\\d+ (ttl=\\d+ )?(.*)(time=(\\d+.\\d+) ms)?';
my $regex = qr/(\w+ (\w+) (\d+) (\d+:\d+:\d+) (\d+)) (?:\d+ bytes )?From (.+)icmp_seq=\d+ (ttl=\d+ )?(.*)(time=(\d+.\d+) ms)?/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}