# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=\?)[^?]*\K\?/&/g;t' <<< "www.domain.com?adult=2&airport=40-48?destination=recko"