re = /(?<=\?)[^?]*\K\?/
str = 'www.domain.com?adult=2&airport=40-48?destination=recko'
subst = '&'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result