using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\?)[^?]*\K\?";
string substitution = @"&";
string input = @"www.domain.com?adult=2&airport=40-48?destination=recko";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}