import Foundation
let pattern = #"(?<=\?)[^?]*\K\?"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"www.domain.com?adult=2&airport=40-48?destination=recko"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"&"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)