const regex = /(?<=\?)[^?]*\K\?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\?)[^?]*\\K\\?', 'g')
const str = `www.domain.com?adult=2&airport=40-48?destination=recko`;
const subst = `&`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);