$re = '/(?<=\?)[^?]*\K\?/';
$str = 'www.domain.com?adult=2&airport=40-48?destination=recko';
$subst = "&";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;