package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?sU)Subscription\/Member ID:\t(.+\b)\tYour Username:\t(.+\b)\nYour Password:\t(.+\b)`)
var str = `blahblahblah
blahblahblah
Subscription/Member ID: 1655107153 Your Username: jose1234
Your Password: jose1234
blahblahblah
blahblahblah
blahblahblah`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}