// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?sU)Subscription\/Member ID:\t(.+\b)\tYour Username:\t(.+\b)\nYour Password:\t(.+\b)").unwrap();
let string = "blahblahblah
blahblahblah
Subscription/Member ID: 1655107153 Your Username: jose1234
Your Password: jose1234
blahblahblah
blahblahblah
blahblahblah";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}