re = /Subscription\/Member ID:\t(.+\b)\tYour Username:\t(.+\b)\nYour Password:\t(.+\b)/
str = 'blahblahblah
blahblahblah
Subscription/Member ID: 1655107153 Your Username: jose1234
Your Password: jose1234
blahblahblah
blahblahblah
blahblahblah'
# Print the match result
str.match(re) do |match|
puts match.to_s
end