use strict;
my $str = 'blahblahblah
blahblahblah
Subscription/Member ID: 1655107153 Your Username: jose1234
Your Password: jose1234
blahblahblah
blahblahblah
blahblahblah';
my $regex = qr/Subscription\/Member ID:\t(.+\b)\tYour Username:\t(.+\b)\nYour Password:\t(.+\b)/sp;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}