const regex = /^www[0-9]*\.((?:[^.\n]*\.)+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^www[0-9]*\\.((?:[^.\\n]*\\.)+)', 'gm')
const str = `www.by
www.ru
www.example.org
www.sub.example.org
`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);