re = /^www[0-9]*\.((?:[^.\n]*\.)+)/m
str = 'www.by
www.ru
www.example.org
www.sub.example.org
'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result