$re = '/^www[0-9]*\.((?:[^.\n]*\.)+)/m';
$str = 'www.by
www.ru
www.example.org
www.sub.example.org
';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;