// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^www[0-9]*\.((?:[^.\n]*\.)+)").unwrap();
let string = "www.by
www.ru
www.example.org
www.sub.example.org
";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}