use strict;
my $str = 'www.by
www.ru
www.example.org
www.sub.example.org
';
my $regex = qr/^www[0-9]*\.((?:[^.\n]*\.)+)/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";