import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^The (\\S+) ball is \\1\\.$";
final String string = "The red ball is red.\n"
+ "The soft ball is soft.\n"
+ "The batman ball is batman.\n"
+ "The batman ball is batmane.\n"
+ "The batman balls is batman.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}