import re
regex = re.compile(r"^The (\S+) ball is \1\.$", flags=re.MULTILINE)
test_str = ("The red ball is red.\n"
"The soft ball is soft.\n"
"The batman ball is batman.\n"
"The batman ball is batmane.\n"
"The batman balls is batman.")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")